UpKeep Analytics Data Sync Delayed
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 09:15 PDT
Identified
Data sync to UpKeep Analytics is delayed and will be resolved shortly. The latest info in Analytics is only up to date as of 3/8 but will be fully synced by 8pm PDT today.
Posted Mar 12, 2024 - 08:52 PDT
This incident affected: UpKeep Web Application.