Some users are reporting that UpKeep Analytics is not loading
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 09:40 PDT
Identified
A fix has been implemented and UpKeep Analytics is now loading. We are still experiencing issues in Asset dashboards and related custom dashboards. The team will continue to investigate.
Posted Apr 21, 2022 - 15:15 PDT
Investigating
We are currently investigating this issue.
Posted Apr 21, 2022 - 08:40 PDT
This incident affected: UpKeep Web Application.