Preventative Maintenance import currently unavailable
Incident Report for UpKeep Maintenance Management
Resolved
Issues with Preventative Maintenance bulk import has been resolved and the feature has been re-enabled.
Posted Mar 28, 2023 - 19:30 PDT
Investigating
Preventative Maintenance bulk import has been temporarily disabled and is unavailable at this time. Teams are working on resolving.
Posted Mar 16, 2023 - 12:38 PDT
This incident affected: UpKeep Web Application.