Some users reporting work order and assets pages not loading
Incident Report for UpKeep Maintenance Management
Resolved
Issue has been resolved. Application is functioning as intended.
Posted Jun 09, 2022 - 15:12 PDT
Monitoring
A fix has been implemented and teams are monitoring.
Posted Jun 09, 2022 - 12:58 PDT
Update
The app is conducting an emergency maintenance.
Posted Jun 09, 2022 - 12:31 PDT
Investigating
Some users reporting work order and assets pages not loading, teams are investigating
Posted Jun 09, 2022 - 12:24 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.