UpKeep Application Impacted

Incident Report for UpKeep Maintenance Management

Resolved

Cloud provider outage has been resolved.
Posted Oct 21, 2025 - 04:20 PDT

Monitoring

Our cloud provider is experiencing a major outage. You may experience slow performance or errors in parts of the application. We are monitoring the situation and will post updates as they are available.
Posted Oct 20, 2025 - 06:55 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, UpKeep Android Application, UpKeep Edge, and UpKeep Datahub.