Some Users are reporting Work Orders Requiring Signature cannot be closed out
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 09:05 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2023 - 14:48 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 24, 2023 - 12:57 PST
Investigating
Our teams are currently investigating the issue
Posted Feb 24, 2023 - 11:00 PST
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.