Application experiencing slow load times - Resolved
Incident Report for UpKeep Maintenance Management
Resolved
Our application is loading as expected and issue with performance has been resolved.
Posted Mar 12, 2024 - 08:43 PDT
Monitoring
The performance issues have been resolved.

*Please note any data changes after ~10 PM PDT on 3/8 will not be available in UpKeep Analytics. We are currently working to resolve this issue.
Posted Mar 11, 2024 - 16:08 PDT
Update
Teams are continuing to work to get the application fully online. At this time, you may experience intermittent unavailability and/or latency in the application while we resolve this issue.

*Please note any data changes after ~10 PM PDT on 3/8 will not be available in UpKeep Analytics until we get this resolved

We apologize for the inconvenience and will get everyone back online as soon as possible.
Posted Mar 11, 2024 - 12:54 PDT
Update
We are continuing to investigate the issue and will update once systems are fully operational.
Posted Mar 11, 2024 - 11:12 PDT
Update
We are continuing to investigate this issue.
Posted Mar 11, 2024 - 11:11 PDT
Investigating
Our application is currently experiencing slow load times, the team is currently investigating.
Posted Mar 11, 2024 - 05:55 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, UpKeep Android Application, and UpKeep Edge.