We are experience heavy load on our servers
Incident Report for UpKeep Maintenance Management
Resolved
This issue has been resolved. We really appreciate your patience and support
Posted Aug 12, 2019 - 09:27 PDT
Monitoring
A fix has been implemented and we are monitoring the incoming traffic load
Posted Aug 12, 2019 - 08:22 PDT
Investigating
We are currently investigating this issue
Posted Aug 12, 2019 - 07:14 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.