UpKeep Work Orders Outage
Incident Report for UpKeep Maintenance Management
Resolved
This issue has been resolved. We deeply apologize about any inconveniences and appreciate your support.
Posted Aug 10, 2019 - 06:13 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2019 - 13:57 PDT
Identified
The issue has been identified. We are working on updating the fix
Posted Aug 09, 2019 - 13:24 PDT
Investigating
We are currently investigating this issue
Posted Aug 09, 2019 - 12:20 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.