Performance Degradation
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 13:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2020 - 08:43 PDT
Identified
The issue has been identified and a fix is being implemented. In the meantime, please expect slower than usual loading times during peak business hours.
Posted Jul 28, 2020 - 13:58 PDT
Investigating
We are currently experiencing performance degradation. Please expect slower than usual loading times.
Posted Jul 28, 2020 - 09:32 PDT
This incident affected: UpKeep Web Application.