Intermittent outages in web and mobile applications
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved and will continue to monitor.
Posted Mar 09, 2021 - 16:10 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2021 - 13:10 PST
Update
We are continuing to investigate this issue.
Posted Mar 09, 2021 - 08:20 PST
Update
Our mobile application is not accessible at this time, we are working swiftly to resolve this issue.
Posted Mar 09, 2021 - 07:47 PST
Investigating
Increased latency times causing slow loading pages in our web application and the Work Orders page is not accessible
Posted Mar 09, 2021 - 06:57 PST
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.