Degraded performance of Android application
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved with a patch fix for Android.
Posted Apr 24, 2020 - 16:17 PDT
Identified
Google Maps is currently experiencing an issue which is impacting our Android application. Once Google administers a fix, our application should be back to normal.
Posted Apr 23, 2020 - 13:52 PDT
This incident affected: UpKeep Android Application.