We're experiencing heavy load on our systems right now that might affect the performance of the app

Incident Report for UpKeep Maintenance Management

Resolved

We're back to normal activities and the issue has been resolved.
Posted Aug 21, 2019 - 13:52 PDT

Monitoring

We're back on track. We're still monitoring the situation but we're now operational.
Posted Aug 21, 2019 - 13:31 PDT

Identified

We're still seeing sporadic performance degradation.
Posted Aug 21, 2019 - 10:55 PDT

Monitoring

Systems are back to operating normally and we're currently monitoring performance.
Posted Aug 21, 2019 - 09:14 PDT

Investigating

We are currently investigating this issue.
Posted Aug 21, 2019 - 07:49 PDT
This incident affected: UpKeep Web Application.