Issue with SSO Login
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 12:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 10:21 PDT
Investigating
We are currently investigating this issue.
Posted Sep 25, 2020 - 09:27 PDT
This incident affected: UpKeep iOS Application, UpKeep Web Application, and UpKeep Android Application.