Preventive Maintenance (Beta) Issue

Incident Report for UpKeep Maintenance Management

Resolved

This incident has been resolved.
Posted Sep 17, 2020 - 18:08 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2020 - 08:09 PDT

Investigating

We're currently having issues with our preventive maintenance triggers creating work orders. We are investigating the issue.
Posted Sep 15, 2020 - 10:29 PDT
This incident affected: UpKeep Web Application.