UpKeep Analytics - reports failing
Incident Report for UpKeep Maintenance Management
Resolved
This incident is now resolved. UpKeep Analytics is fully operational and stable.
Posted Feb 26, 2021 - 17:10 PST
Monitoring
UpKeep Analytics is back up and running. Our teams will continue to monitor for stability.
Posted Feb 26, 2021 - 16:11 PST
Investigating
Some reports inside of UpKeep Analytics are failing to load. Our team is currently investigating.
Posted Feb 26, 2021 - 13:00 PST
This incident affected: UpKeep Web Application.