Editing PM Trigger Issue
Incident Report for UpKeep Maintenance Management
Resolved
A fix has been implemented and we have resolved the issue.
Posted Nov 12, 2020 - 17:11 PST
Identified
We have identified an issue when editing PM triggers where the start date is reset upon editing. We are implementing a fix and the issue should be resolved shortly.
Posted Nov 05, 2020 - 09:38 PST
This incident affected: UpKeep Web Application.