Bulk import for work orders is currently unavailable.
Incident Report for UpKeep Maintenance Management
Resolved
This incident has been resolved.
Posted Aug 28, 2020 - 10:33 PDT
Investigating
We are currently investigating this issue.
Posted Aug 26, 2020 - 11:59 PDT
This incident affected: UpKeep Web Application.