Locations on Web is intermittently not working
Incident Report for UpKeep Maintenance Management
Resolved
We're back to normal operations.
Posted Mar 23, 2020 - 09:51 PDT
Identified
We're experiencing an issue with the ability to assign locations to work orders on the web. We've identified the issue and we're currently resolving it.
Posted Mar 23, 2020 - 08:42 PDT
This incident affected: UpKeep Web Application.